読者です 読者をやめる 読者になる 読者になる

My days of...

生活のことなど

vagrant upをしたらGuestAdditionsのバージョンが違うとメッセージが出たので・・・


久しぶりにVagrantを使おうと思ってvagrant upとすると、

Got different reports about installed GuestAdditions version:
Virtualbox on your host claims: 4.3.28
VBoxService inside the vm claims: 5.0.10

なメッセージが表示。書いてある通りGuestAdditionsのバージョンが違うとのこと。

前回Vagrantを使おうとした時も同じようなメッセージが出たような気がする、と思いながら解決方法を検索。

blog.bgbgbg.net

こちらのサイトで紹介されている通り、

vagrant plugin list

を行い、vagrantプラグインを表示。

vagrant-hostsupdater (1.0.1)
vagrant-omnibus (1.4.1)
vagrant-share (1.1.5, system)
vagrant-vbguest (0.11.0)

4つプラグインを入れていたので、

vagrant plugin install vagrant-vbguest

としてvagrantプラグインvagrant-vbguestを最新版へ変更。

Installed the plugin 'vagrant-vbguest (0.11.0)'!

と表示されたので、vagrant reload。
すると、今度はメッセージが表示されず。取り敢えず、解決できた。

しかし、vagrant-vbguestのバージョンが変わっていないので、なんだか不思議。

 

Vagrant入門ガイド

Vagrant入門ガイド